Nets Easy delay in payouts - INC0492953
Incident Report for Nets Easy
Resolved
This incident has been resolved, payouts have been done today.
Posted Jan 19, 2023 - 09:00 CET
Identified
Transactions from mainly 09/01 and 11/01 along with a few other dates in SEK,GBP,PLN and CHF with payout date 16/1 are delayed and will be settled 19/1
Posted Jan 16, 2023 - 09:00 CET
This incident affected: Nets Easy Payouts.