Disturbance on Nets Easy Portal
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 09:00 CET
Investigating
We are currently investigating an issue that causes Nets Easy Portal to show an internal server error.
Posted Feb 01, 2024 - 07:45 CET
This incident affected: Nets Easy Merchant Portal.