Easy payment issue
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jul 06, 2022 - 19:50 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 06, 2022 - 19:29 CEST
Investigating
Our tech-team is currently investigating a issue that are affecting payments.
Posted Jul 06, 2022 - 17:00 CEST
This incident affected: Nets Easy Checkout.