Disturbance on Nets Easy - INC0673288
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Oct 04, 2024 - 12:21 CEST
Monitoring
Transaction levels are stabilizing, we will continue to monitor the situation.
Posted Oct 04, 2024 - 12:20 CEST
Investigating
We are investigating an issue impacting transactions on Nets Easy.
Posted Oct 04, 2024 - 11:50 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.