Disturbance on Nets Easy - INC0649836
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 12:10 CEST
Investigating
We are currently investigating this issue.
Posted Jul 30, 2024 - 11:27 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.