Issues with data center outside Nets/Nexi - INC0705237
Incident Report for Nets Easy
Resolved
An external service provider has confirmed issues that had some impact on 3DS transactions for certain cardholders
Posted Jan 06, 2025 - 09:07 CET
Investigating
We are currently investigating an increased failure rate on 3DS transactions
Posted Jan 06, 2025 - 07:15 CET
This incident affected: Nets Easy Checkout.