External 3D Secure issues
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 19:39 CEST
Monitoring
Some VISA transactions are now getting accepted again but we still see issues with 3D Secure.
We will continue to monitor the situation.
Posted Jul 20, 2022 - 18:00 CEST
Update
We now see that all VISA 3D Secure transactions are failing.
No issues with Mastercard.
Posted Jul 20, 2022 - 15:30 CEST
Identified
We are currently seeing external issues with 3D Secure.
Cardholders might experience timeouts, VISA cards seems to be affected more than Mastercards.
Posted Jul 20, 2022 - 12:15 CEST
This incident affected: Nets Easy Other Components.