Issue displaying balance in Easy Portal - INC0701001
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Dec 17, 2024 - 14:43 CET
Investigating
We currently have an issue displaying balance in Easy Portal. We are investigating the problem.
Posted Dec 17, 2024 - 11:46 CET
This incident affected: Nets Easy Merchant Portal.