Delayed payout reports - INC0899984

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 16:42 CEST

Update

Processing of reports is still ongoing, we will provide an update as soon as reports are available.
Posted Apr 01, 2026 - 16:07 CEST

Identified

Payout reports are currently delayed.
Payouts themselves are being processed as usual and are not affected by this issue.
Posted Apr 01, 2026 - 08:31 CEST
This incident affected: Nets Easy Merchant Portal.