Disturbance on Nets Easy - INC0760242

Incident Report for Nets Easy

Resolved

The issue was related to ACS and has been resolved with minor impact.
Posted May 21, 2025 - 12:40 CEST

Investigating

We are currently investigating an elevated failure rate
Posted May 21, 2025 - 12:28 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.