Disturbance with onboarding of new merchants - INC0604239
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 14:35 CET
Investigating
We are currently investigating an issue affecting the onboarding of new merchants.
Posted Mar 26, 2024 - 07:00 CET
This incident affected: Nets Easy Other Components.