3D-Secure transaction issue - INC0588326
Incident Report for Nets Easy
Resolved
The issue has been resolved.
Posted Jan 29, 2024 - 23:33 CET
Identified
We have identified an issue causing 3D-Secure card transactions to time out.
Our tech team is working on a solution.
Posted Jan 29, 2024 - 18:22 CET
This incident affected: Nets Easy Checkout and Nets Easy API.