Slow checkout window - INC0607728
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Apr 07, 2024 - 15:20 CEST
Investigating
We are investigating an issue that causes the payment window to response slower then usual
Posted Apr 07, 2024 - 13:55 CEST
This incident affected: Nets Easy Checkout.