Disturbance on Swish - INC0671205
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Sep 30, 2024 - 09:10 CEST
Identified
We have identified issues with Swish transactions getting declined.
Posted Sep 30, 2024 - 08:20 CEST
This incident affected: Nets Easy Checkout and Nets Easy Other Components.