Nets Easy portal issues - INC0727065

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 14:05 CET

Identified

We have identified an issue affecting functionality in the Nets Easy portal.
Our tech team is working on a solution.
Posted Mar 03, 2025 - 12:53 CET
This incident affected: Nets Easy Merchant Portal.