Instability on MitID - INC0713419
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jan 26, 2025 - 13:30 CET
Identified
Instability observed on MitID impacting 3D-Secure transactions.
Posted Jan 26, 2025 - 12:27 CET
This incident affected: Nets Easy Checkout and Nets Easy API.