Portal search issue

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 12:00 CEST

Identified

We are currently experiencing an issue where merchants are unable to search for payments using Order ID in the Payments tab.
Searching still works using other criteria such as name and amount.

Our team is actively working on a fix and we will share an update as soon as possible.
Posted Apr 24, 2026 - 09:00 CEST
This incident affected: Nets Easy Merchant Portal.