Disturbance at Swish - INC0760919

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted May 22, 2025 - 16:08 CEST

Identified

Swish has confirmed issues impacting Swish payments.
https://status.swish.nu/incidents/4nsk2krv9c32
Posted May 22, 2025 - 13:10 CEST
This incident affected: Nets Easy Other Components.