Disturbance on MitID - INC0743950

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 14:56 CEST

Investigating

We currently investigating an issue on MitID impacting 3D-Secure transactions.
Posted Apr 14, 2025 - 14:01 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.