Elevated errors on MasterCard - INC0944262

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 10:55 CEST

Investigating

We are currently investigating an issue with elevated MasterCard failures.
Posted Jul 15, 2026 - 09:00 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.