Delay in settlement report - INC0612519
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 15:30 CEST
Identified
We are currently working on an issue that causes a delay in settlement reports. Payouts are not affected.
Posted Apr 18, 2024 - 09:00 CEST
This incident affected: Nets Easy Merchant Portal.