MitID issue - INC0887876

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 11:45 CET

Identified

Signaturgruppen has reported that MitID is currently unavailable, impacting card transactions that require 3DS authentication.
https://status-prod.signaturgruppen.dk/incidents/ql4jm89pcvf5
Posted Feb 27, 2026 - 10:10 CET
This incident affected: Nets Easy Checkout and Nets Easy API.