Disturbance on Nets Easy - INC0937166

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 22:15 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 22:15 CEST

Identified

We have potentially identified the root cause of the issue affecting Nets Easy online payments.
A hotfix is being prepared and will be deployed shortly.
Posted Jul 02, 2026 - 22:05 CEST

Update

We are continuing to investigate this issue.
Posted Jul 02, 2026 - 20:50 CEST

Investigating

We are currently experiencing issues with Nets Easy which is affecting online payments.
Our team is actively investigating the issue.
Posted Jul 02, 2026 - 19:00 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.