Issues with Shopify payment window - INC0612589
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 11:58 CEST
Investigating
We are currently investigating an issue that might affect Shopify payments
Posted Apr 18, 2024 - 10:23 CEST
This incident affected: Nets Easy Checkout.