Elevated error rate on Visa transactions - INC0634910

Incident Report for Nets Easy

Resolved

VISA has acknowledge the incident in their network and communicated that the issue has been mitigated.
Posted Jun 18, 2024 - 12:40 CEST

Investigating

We are currently investigating this issue.
Posted Jun 18, 2024 - 10:36 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.