INC0462025 - Delay in Easy payouts
Incident Report for Nets Easy
Resolved
We have paid out the majority of transactions expected for today.
Some partial charges and refunds have been processed today and will be paid out on Monday.
Posted Sep 23, 2022 - 17:25 CEST
Update
A number of transactions charged on Thursday 15/9 with payout date for Tuesday 20/9 and Wednesday 21/9 has previously been reported delayed for payout.
Part of these transactions are currently getting processed and expected to get paid out tomorrow Thursday 22/9.
Remaining transaction are expected to get paid out Friday 23/9.

Also transactions charged Thursday 15/9 with payout date for tomorrow 22/9 are at this point delayed as well and are expected to be processed tomorrow and paid out Friday 23/9 instead.
Posted Sep 21, 2022 - 17:19 CEST
Update
Transaction payouts and refunds with payout date for Tuesday 20/9 and Wednesday 21/9 is also expected to be delayed.
Posted Sep 16, 2022 - 18:35 CEST
Identified
An issue with payouts and refund transactions has been identified.
The affected transactions are supposed to be settled Monday 19/9 but will at this point be settled Tuesday 20/9.
Kindly follow status page for updates.
Posted Sep 16, 2022 - 16:45 CEST
This incident affected: Nets Easy Payouts.