Disturbance on Nets Easy - INC0597405
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 12:56 CET
Investigating
We are currently investigating an issue affecting card transactions.
Posted Mar 01, 2024 - 12:00 CET
This incident affected: Nets Easy Checkout and Nets Easy API.