Portal login issue - INC0606435
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 11:34 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 03, 2024 - 11:20 CEST
Identified
We are currently experiencing issues with Nets Easy portal.
Our tech team is working on a solution.
Posted Apr 03, 2024 - 10:55 CEST
This incident affected: Nets Easy Merchant Portal.