Delayed payout reports - INC0816871

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 13:24 CEST

Identified

Payout reports are currently delayed.
Payouts themselves are being processed as usual and are not affected by this issue.
Posted Sep 02, 2025 - 08:20 CEST
This incident affected: Nets Easy Merchant Portal.