Disturbance on MitID- INC0768452

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 09:10 CEST

Investigating

We currently investigating an issue on MitID impacting 3D-Secure/Dankort transactions.
Posted Jun 10, 2025 - 08:50 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.