Shopify issue - INC0645073
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 15:18 CEST
Investigating
We are currently investigating an issue possible affecting transactions on Shopify.
Posted Jul 15, 2024 - 13:08 CEST
This incident affected: Nets Easy Plug-ins.