Delay in Easy payouts

Incident Report for Nets Easy

Resolved

The files has been resent today and the payout for the delayed transactions will happen tomorrow,
Posted Sep 05, 2022 - 09:52 CEST

Identified

Due to a technical issue a limited number of Nets Easy transactions that should have been payed out today are delayed in payout.
Our team is working on a solution to get these transactions payed out on Monday.
Posted Sep 02, 2022 - 13:00 CEST
This incident affected: Nets Easy Payouts.