Phone system is currently not working
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jun 27, 2022 - 19:00 CEST
Identified
Nets Ecom support phonelines are currently not working.
We are working on a solution.
Posted Jun 27, 2022 - 13:30 CEST
This incident affected: Nets Easy Other Components.