Incorrect transaction status on Nets Easy Portal - INC0624125
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted May 28, 2024 - 15:41 CEST
Monitoring
All new cases have been corrected. Settlement reports are in generation and should be available for download within next 3 hours.
We keep monitoring the situation.
Posted May 27, 2024 - 16:42 CEST
Identified
We identified more cases about transaction status on Nets Easy Portal
Posted May 27, 2024 - 10:14 CEST
This incident affected: Nets Easy Merchant Portal.