Error in Nets Easy Checkout - INC0871532

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 13:30 CET

Identified

Some customers may be unable to complete their purchase due to an error in the payment window stating: “This shop does not deliver to your country. Try to use an address in a supported country.”
Posted Jan 19, 2026 - 13:30 CET
This incident affected: Nets Easy Checkout.