Nets Easy sign-up issue - INC0780002

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 16:30 CEST

Identified

We have identified an issue causing a 500 error for new merchants attempting to sign up.
Our tech team is actively working on a solution.
Posted Jul 01, 2025 - 14:30 CEST
This incident affected: Nets Easy Other Components.