Swedbank Swish issue

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Sep 25, 2025 - 12:28 CEST

Identified

Swedbank is experiencing a disturbance that may impact Swish transactions.
https://status.swish.nu/incidents/wxpb5pywxr33
Posted Sep 25, 2025 - 12:17 CEST
This incident affected: Nets Easy Other Components.