Delay in settlement report - INC0622576

Incident Report for Nets Easy

Resolved

This incident has been resolved. Reports take one hour to process until they are available within Nets Easy Portal
Posted May 17, 2024 - 11:45 CEST

Investigating

We are currently working on an issue that causes a delay in settlement reports. Payouts are not affected.
Posted May 17, 2024 - 08:00 CEST
This incident affected: Nets Easy Merchant Portal.