Swish issues

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 15:31 CET

Identified

Swish has confirmed issues impacting Swish payments.
https://status.swish.nu/
Posted Mar 05, 2025 - 14:18 CET
This incident affected: Nets Easy Other Components.