Delay in Easy payouts

Incident Report for Nets Easy

Resolved

The remaining delayed payouts are currently getting payed out.
If any transactions are delayed at this point they should kindly be reported to our support teams for normal support handling.
Posted Jun 20, 2022 - 12:00 CEST

Update

A small number of transactions are still remaining to get payed out.
Our tech team is still working on the issue.
Posted Jun 09, 2022 - 14:40 CEST

Update

The majority of delayed payouts has been payed out today and we are working on the remaining cases with high urgency.
Posted Jun 08, 2022 - 10:32 CEST

Identified

We currently have a 1-2 day delay in payouts.
Posted Jun 07, 2022 - 15:00 CEST
This incident affected: Nets Easy Payouts.