Easy test issues
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 11:30 CEST
Identified
We are currently having issues with Easy test environment.
Our tech team is working on a solution.
Posted Jun 13, 2022 - 10:30 CEST
This incident affected: Nets Easy Customer Test.