Disturbance on Nets Easy - INC0899560

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 14:08 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 31, 2026 - 13:40 CEST

Update

We are continuing to work on a fix for this issue.
Posted Mar 31, 2026 - 12:57 CEST

Identified

The issue has been identified within MitID and is mainly affecting Dankort transactions. We are currently working on resolving the issue
Posted Mar 31, 2026 - 09:22 CEST

Investigating

Our systems indicate an issue with 3DS transactions
Posted Mar 31, 2026 - 08:50 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.