Delayed payout reports - INC0780302

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 14:07 CEST

Update

Update:
majority of the reports are available now.
we expect that all the rest will be available within one hour.
Posted Jul 02, 2025 - 12:51 CEST

Identified

Payout reports for today are delayed until further notice.
Payouts are not impacted.
Posted Jul 02, 2025 - 09:00 CEST
This incident affected: Nets Easy Merchant Portal.