Issues on Nets Easy - INC0632110
Incident Report for Nets Easy
Resolved
This incident has been resolved.
Posted Jun 11, 2024 - 11:01 CEST
Investigating
We are currently investigating an issue affecting transactions on Nets Easy.
Posted Jun 11, 2024 - 10:48 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.