Outage on Nets Easy - INC0916257

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted May 22, 2026 - 08:03 CEST

Update

Operations have been stable again since 17:10
Posted May 21, 2026 - 17:10 CEST

Update

We are experiencing transaction impact again since 16:57
Posted May 21, 2026 - 16:57 CEST

Update

Operations have been stable since 14:35, we will continue to monitor the situation closely.
Posted May 21, 2026 - 14:35 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 21, 2026 - 14:07 CEST

Identified

We are still addressing the ongoing network issue. While resolution is taking longer than expected, our engineers are actively working to restore full service. We appreciate your understanding.
Posted May 21, 2026 - 11:12 CEST

Update

We are continuing to work with highest priority on a fix for this issue.
Posted May 21, 2026 - 10:15 CEST

Investigating

Transactions are impacted.
We are currently investigating this issue.
Posted May 21, 2026 - 09:05 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.