Disturbance on Nets Easy
Incident Report for Nets Easy
Resolved
This incident has been resolved with minor impact.
Posted Oct 09, 2024 - 12:53 CEST
Investigating
We are investigating an issue impacting card transactions on Nets Easy.
Posted Oct 09, 2024 - 12:30 CEST
This incident affected: Nets Easy Checkout and Nets Easy API.