Delay in settlement report delivery - INC0605708
Incident Report for Nets Easy
Resolved
This incident has been resolved and remaining reports will be provided this night.
Posted Apr 02, 2024 - 20:30 CEST
Investigating
We are currently investigating an incident that cause settlements reports delayed.
Posted Apr 02, 2024 - 08:00 CEST
This incident affected: Nets Easy Merchant Portal.