Tietoevry Banking Incident - INC0724662

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 14:25 CET

Identified

An external provider has confirmed an incident affecting 3D Secure transactions - as a result we are seeing elevated failure levels on our platforms.
Posted Feb 24, 2025 - 13:34 CET
This incident affected: Nets Easy Checkout and Nets Easy API.