Disturbance at VippsMobilePay - INC0723350

Incident Report for Nets Easy

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 15:50 CET

Identified

VippsMobilePay is experiencing an issue with their App login affecting some users.
Posted Feb 19, 2025 - 15:00 CET