Delays in refunds and payouts

Incident Report for Nets Easy

Resolved

The delayed transactions have now been processed and are currently getting payed out to merchants and refunded to cardholders according to settlement agreement.
Posted Jun 27, 2022 - 11:00 CEST

Update

The delayed transactions have been sent to processing and will be beginning to get payed out tomorrow Friday 24/6
Posted Jun 23, 2022 - 16:00 CEST

Identified

We have identified a issue with delays on refunds and payouts on some transactions made 31.05.2022 - 07.06.2022
Our tech-team is working on a solution to process the refunds back to cardholders as soon as possible.
Posted Jun 23, 2022 - 12:00 CEST
This incident affected: Nets Easy Payouts.